viernes, 7 de junio de 2013


Instalación de RaptorCache 1.0b
Raptorcache es un sistema proxy cache que se caracteriza por almacenar contenido dinámico, lo cual nos permite guardar diferentes tipo de contenido  al momento de navegar, para luego si se hace la misma petición sea entregado  desde el servidor lo cual nos ahorraría el ancho de banda de internet, también esta entrega que se hace desde el servidor se efectuaría a una velocidad mayor lo cual ofrecería una mejor calidad de servicio.
Para instalar tenemos que seguir los siguientes pasos.

1.- Primero tenemos que instalar Debían, se puede descargar de los siguientes enlaces.

32 bits
http://cdimage.debian.org/debian-cd/6.0.7/i386/iso-cd/debian-6.0.7-i386-netinst.iso

64 bits
http://cdimage.debian.org/debian-cd/6.0.7/amd64/iso-cd/debian-6.0.7-amd64-netinst.iso

Luego procedemos a instalar Debian como se muestra en el video.


2.- Instalamos el Raptorcache en Debian para eso procedemos a ingresar los siguientes comandos por el terminal que ejecutara el script de instalación (se puede hacer tambien esto utilizando putty).

Para esta instalación tomaremos como ejemplo el siguiente esquema.


Es importante que durante la instalación del RaptorCache poner la contraseña del Mysql: raptor

32 bits
Código:
  1. wget http://www.raptorcache.com/install/raptor10b-32.sh
  2. chmod 777 raptor10b-32.sh
  3. bash raptor10b-32.sh

64 bits
Código:

  1. wget http://www.raptorcache.com/install/raptor10b-64.sh
  2. chmod 777 raptor10b-64.sh
  3. bash raptor10b-64.sh

3.- Redireccionamos y priorizamos el trafico de Raptor en Mikrotik con las siguientes reglas.

Código:
  1. /ip firewall filter
  2. add action=accept chain=forward comment="Acepta RaptorCache" disabled=no src-address=192.168.10.0/30
  3. /ip firewall nat
  4. add action=dst-nat chain=dstnat comment="Redirect Raptorcache" disabled=no dst-port=80 protocol=tcp src-address=!192.168.10.2 to-addresses=192.168.10.2 to-ports=3128
  5. /ip firewall mangle
  6. add action=mark-connection chain=postrouting comment="== RAPTORCACHE ==" content="X-Cache: HIT from Raptor" disabled=no new-connection-mark=raptor-connection passthrough=yes src-address=192.168.10.2 protocol=tcp
  7. add action=mark-packet chain=postrouting connection-mark=raptor-connection disabled=no new-packet-mark=raptor-packs passthrough=yes
  8. add action=mark-connection chain=postrouting comment="== SQUID ==" content="X-Cache: HIT from proxy.os.com" disabled=no new-connection-mark=squid-connection passthrough=yes src-address=192.168.10.2 protocol=tcp
  9. add action=mark-packet chain=postrouting connection-mark=squid-connection disabled=no new-packet-mark=squid-packs passthrough=yes
  10. /queue tree
  11. add burst-limit=0 burst-threshold=0 burst-time=0s disabled=no limit-at=0 max-limit=4M name="RaptorCache" packet-mark=raptor-packs parent=global-out priority=4 queue=default
  12. add burst-limit=0 burst-threshold=0 burst-time=0s disabled=no limit-at=0 max-limit=4M name="Squid 3.x" packet-mark=squid-packs parent=global-out priority=4 queue=default

4.- Entramos por el navegador web para ver la interface gráfica Raptor Webpanel.
Para ingresar a ver el Webpanel de ingresa poniendo la siguiente dirección en el navegador web.
http://IP_DEL_SERVIDOR:82

En el caso del esquema sería:
http://192.168.10.2:82

Nombre de Usuario=admin
Contraseña=admin
Categories:

6 comentarios:

  1. buenas noches tengo un problema tengo instalado raptor cache pero no me cachea porque en reporte no sale ninguno si alguien me puede hacer el favor le agradesco por favor cual infomacion este es mi correo:

    juanfranciscosuarezsuarez@gmail.com

    ResponderEliminar
  2. Verifica primero, los factores generales:
    El equipo tiene el minimo de requerimentos.
    La instalacion se ocmpleto sin percances.
    Realizaste la redireccion al 82(u otro que hayas implementado), del raptor en su ip.
    Verificaste por putty si el debian estaba en el login. "opcional"

    Chequea esto a ver sino hubo ningun problema.

    ResponderEliminar
  3. saludo tienes la configuracion del mikrotik al RaptorCache , tengo por DHCP , para los clientes utilizo hostpot

    ResponderEliminar
  4. buenas tardes, puedo usar el raptor sin un servidor mikrotik?

    ResponderEliminar
  5. mi servidor no hace cache de youtube alguien me ayuda?

    ResponderEliminar
  6. Si el raptor no cachea, cual son los problemas principales.

    ResponderEliminar

Subscribe to RSS Feed Follow me on Twitter!